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Part 1.  Session Contents  

1. Self-Intros  
2. What are your interests regarding Excel?   
3. What have your work experiences been with Excel (if any)?  
4. What questions would you like to have answered in this session (to be satisfied)?   

 
Zoom Screen Sharing for a F2F Session:  Zoom setup for the F2F session, so those sitting at the back can see my screen:  
https://ksu.zoom.us/j/6752623021      (I will not be sharing sound via Zoom in a F2F presentation.)     
Fully Online Zoom:  For a fully online Zoom presentation, sound will be used through the web conferencing tool. 
 
My One Goal Today:  I want you all to give Excel a try.  (Please don’t try to memorize how to use Excel.  I want you to 
just remember capabilities and maybe a referent name to that capability…and those capabilities and how to achieve 
them can all be found online (on web pages, in videos, and so on).  While there are some references to some more 
sophisticated capabilities, my plan is not to do walk-throughs of all of them…because the pacing of actually working 
these out is slower than the pace of a presentation.)   

If you already use Excel for work or pleasure, please just try some new function or feature of the tool.     
Use of Excel should be fun and stress free.   

 
Here is the general plan.   

 
HOUR ONE:  The Walk-throughs and Demoing  

 
• Creating a workbook (with spreadsheets)  
• Ingesting data (.csv / comma separated values; .tsv / tab separated values; database data tables, and others?)  
• Creating spreadsheets  
• Cleaning data (de-duplicating, removing untrustworthy data, removing anomalous datapoints for some types 

of statistical analysis, and others)  
• Filtering data  
• Applying simple formulas to data  
• Running a fill handle / using autofill (properly)  
• Navigating in the data  
• Searching and finding in the data  
• Creating data visualizations (based on the data, based on data visualization conventions)  
• Labeling data visualizations (in terms of axes, titles, data labels, legends, and others) 
• Using built-in visuals [automated data visualizations (and starting to line up visuals with the data)]  

 
• Troubleshooting together  

 
 

HOUR TWO:  Some More Advanced Walk-throughs 
 

• Intensity matrices / intensity tables by frequencies (conditional formatting - > color scales)   
 

• Combo charts with 2 y-axes (like a Pareto chart, which is a type of histogram)  
 

• Custom cell formatting (positive numbers; negative numbers; handling of zero) ;  
• Conditional formatting  

 
• Excel templates (Business, Personal, Planners and Trackers, Lists, Budgets, Charts, and Calendars)  

 

https://ksu.zoom.us/j/6752623021
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• Data downloads from various sites in Excel format  
 

• Using various add-ons to Microsoft Excel (such as some of the features of NodeXL or others)   
 

• Accessing and assessing all macros in an inherited Excel workbook, accessing and assessing all formulas in an 
inherited Excel workbook  
 

• Other topics (based on your own preferences)   
 

 
Part 2.  Some Basic Uses of Excel (O365)   
 
Excel is often used to achieve the following:   
 

• conduct calculations,  
• clean data,  
• graph or plot data (to identify data patterns),  
• create data visualizations (both static and interactive),  
• apply visual styles to data tables and data visualizations,  
• create interactive data visualizations (interactive pivot tables, interactive dashboards with slicers, and others),  
• create simple macros (sets of directions, scripts) for continuing data handling (with Visual Basic programming 

language),  
• process data for analytics in other software programs,  
• enable the share-ability of information,  
• access online survey data (in analyze-able format), and more  

 
Starting a Data Workbook:   

• An Excel workbook may be created from scratch manually.   
• It may be created from pasted data.   
• It may be created from available data in an existing file (which is loaded into an Excel workbook). 
• It may be downloaded from a database.   
• It may be downloaded from an online survey system (like Qualtrics).   
• Or it may be created from some combination.   

 
Avoiding Data “Lossiness” (Data Loss).  Worksheets are limited to 1,048,576 rows by 16,384 columns.  (When using the 
computer “clipboard” to copy-paste data, those limits are lower, so be careful when moving data to make sure that you 
don’t permanently lose anything.)   
 

 
 
Data Extractions from Application Programming Interfaces (APIs):  With add-ons and other packages, it is possible to 
conduct some data extractions from social media platforms (NodeXL/Network Overview, Discovery and Exploration for 
Excel), create data streamgraphs, and achieve other aims.  These are sometimes free.  (Make sure to go to trusted sites 
only to download these to avoid downloading malware lurking in some programs.)    
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Connected Web Version:  There is a free Web version with a Microsoft account.  This is part of the Free Office Online 
apps (https://products.office.com/en/office-online/), which require a desktop browser and a Microsoft log-in.   
 
About the Online Version of Excel:  The online version of Excel has some limits in terms of features, but it offers other 

conveniences, like auto-save (to the cloud to the account on OneDrive and 
SharePoint), multi-device access, etc.   
 
Engaging Quick Analysis:   
 
There are a lot of built-ins in Excel that enable fast exploration of data.  To 
access one, just highlight your data…and click the button at the bottom right.   
 
Those who prefer to make their own formulas may do so using pre-written 
formulas…  Or they can write their own formulas based on basic operands 
and directions (operations).  A relative cell reference is assumed in most 
cases.  This is when a selected cell is defined based on its locational 
relationship to the activated cell directionally.  For absolute (location defined 
and set) cell references, use the F4 or the $ in front of each part of the 
formula ($columnreferent,$rowreferent) to lock down the referent.  A 
locked-down referent uses the exact indicated cell again and again, and the 
referred-to cell does not change even if the original cell pointing to that 
target cell does.  (The default setting is to have relative cell references, unless 

otherwise indicated.)   
 
Data Visualizations from Excel:   

1. The data visualizations may be kept in the Excel file (.xlsx, not .csv file formats), and the Excel file may be shared.  
2. The data visualizations may be shared online on Office 365’s various Groups and SharePoint and others…for 

interactive experiential access and downloads.   
3. The visuals may be shared in a document as a linked visual to the underlying dataset.  Any changes to the 

underlying dataset will affect the data visualization. (This is done with a simple copy and paste from Excel 
directly.  The underlying data files should not be moved from the respective locations, or that will result in an 
empty visualization. The files are linked locally, so folder structures and names and such matter.)   

4. The visuals may be shared as a .pdf file (with text-readable text using screen readers).   
5. The visuals may be shared as a data graphic in either vector or raster / bitmap formats.  (In this case, the graph 

may be captured with a screenshot and rendered in a digital image editing tool.  Images do not carry inherent 
data in terms of screen readers, so the lead-up and lead-away text, the captioning, the alternative text…should 
all be as informative as possible.)   

 
Excel in a Work Pipeline 

Work Sequences (or “Pipelines”):  Knowing what may be imported (into) and exported (out of) Excel is important 
because Excel may be part of a basic work sequence involving other technologies.  For Excel to be able to “talk” with 
these other software tools, it is important to know what the imports / exports file types are.   
 
File Versioning:  Also, these file types enable versioning…or creating different versions of a basic file…for uses in 
different contexts.  (The first “pristine” version of the dataset or workbook should be preserved in its original state, 

Figure 1.  The Quick Analysis Tool in Excel for an 
Initial Glance at the Data 

https://products.office.com/en/office-online/
https://support.microsoft.com/en-us/office/switch-between-relative-absolute-and-mixed-references-dfec08cd-ae65-4f56-839e-5f0d8d0baca9
https://support.microsoft.com/en-us/office/switch-between-relative-absolute-and-mixed-references-dfec08cd-ae65-4f56-839e-5f0d8d0baca9
https://commons.wikimedia.org/wiki/File:W_cloud.svg
https://creativecommons.org/licenses/by-sa/3.0/
https://creativecommons.org/licenses/by-sa/3.0/
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without changes, in order to protect the data against mishandling or unintended changing.  The individual can always 
return to the original data and start fresh.)   
 

Avoiding Data Loss 
 
Avoiding File Lossiness:  Some file types are “lossy” and will lose information, so even if one starts out with a particular 
file type, it may make sense to save out the file in a different format.   
 
(One example is opening a .csv / “comma separated values” file of data but saving out as a .xlsx (XML spreadsheet) if you 
create data graphs and plots…because the .csv version will lose your visuals and result in repeated work.)   
 
Also, changing the data format of a data column may result in data loss.  One simple example is removing decimal places 
to the right of the decimal point.  Another is changing date information into general information.  The idea is to not 
accidentally create data problems.  (Keep a master file that is pristine and unedited so there is a backup.)   
 

Ensuring visual quality in Excel workbook:  It is possible to place 
various digital contents, like images, into an Excel table as well.  
If you need to retain high resolution, open a workbook with 
data.  Go into File -> Options -> Advanced -> Image Size and 

Quality -> and check on “Do not compress images in file” and set 
“Default resolution” to “High fidelity.”   
• Only then would you start loading in visual images by the 
“Insert” tab.   
• This setting is not retroactive.   
 
 
 
  

Figure 2.  Preserving Digital Image Spatial Resolution with Pre-
settings in the Excel Workbook 
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Import / Export File Types and Features   
 

Import (file -> open -> browse -> file types)  Export 
(file -> save as …)  
(file -> export …)  
(file -> publish … )  
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Many use Excel to codify data tables for documents (in Word, in PowerPoint, in Adobe Acrobat), in databases, and in 
LaTeX files (for manuscripts, for dissertations).   
 
Part 3.  A Bit about Traditional Structured (Labeled) Data  
 
Basic Table Structure of Traditional Structured Data  
 

 Column 
Headers  
(usually 
variable data) 
…   

      

Row Headers 
(usually 
individual 
records)  …   

Data cells       

        

 
Many datasets forgo actual labels to the columns if the contents are generally understood, or the documentation for the 
data is documented in a data dictionary or README documentation.  Excel accepts a number of structured data as 
imports.   
 
Common “Data Types” in Cells  

• Labels (usually as alphanumeric or text-only characters)  
• Values (usually raw numbers, dates, and others)  
• Formulas (directions to Excel for how to perform calculations)  

 
“Structured” data is labeled data, usually in data arrays or data tables. They are “structured” because they are 
formatted in ways that enable their processing in different software programs and of recognizable types.  [By contrast, 
semi-structured or un-structured data are textual documents, imagery, videos, audio files, mixed-modal files, and 
others, because these have more subtle types of structuring…not the explicit data table structures of classic quantitative 
data.  Some argue that there is no such thing as fully unstructured data because everything has some pattern, even if it 
is non-obvious to the naked eyes.]  Excel can handle both structured and semi-structured / unstructured data of various 
types.    
 Layout-wise, Excel has some challenges in handling images in its data cells, though.  It takes some work to center 
a series of thumbnails in a data cell…  Those who want the thumbnail to link to a full-size image need to make the image 
a link to the actual image (hosted on an available site).   
 
Data types take particular formats, and changing the data types in the column data can affect how the spreadsheet is 
ingested into databases (or not).  Changing the data types may also cause problems with the data itself and may lose 
specificity from some types of data to others.  Saving a workbook as a particular file type may also result in lost data if 
the format is not the right type to maintain the level of information.    
 
[Going with .xlsx and not .csv to maintain data visualizations:  For example, a file opened as a .csv but then edited to 
include data visualizations should be saved out as a .xlsx file to keep the visuals.  Otherwise, the data visualizations will 
be lost if the file is resaved as a .csv.]  Data visualizations are usually summary data, to capture higher level data 
patterns.  Some data visualizations may be made interactive in Excel, such as in pivot tables, data platforms with data 
filtering, and others.   
 
Data formats.  The data formats may be set for each column of data, assuming that the data is structured data and all of 
a type in the column.  The settings will affect how the cells are displayed and may change (numerical) input data…so it 
helps to know what the formatting is applied to each cell and how it affects the data.  (This is especially true with 
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inherited data from databases, data tables sent by colleagues, downloaded datasets, and so on.  With inherited data or 
other types of data, always save a “pristine” master set before making any changes to the data…so you can go back to 
an anchor point before changes were made.)    
 
General:  default numbers, no understood format   
Number:  positive numbers, negative ones, up to 30 decimal places, may include the comma separator at each of three 
digits  
Currency:   any of hundreds of symbols for currency indicators, three-letter indicators for currency indicators, and others  
Accounting:  number representations for accounting, ( ) to indicate something of the amount, and others   
Date:  variety of representations of month, day, year; month; month-day, and other representations of  

Time:  hour, minute, second and AM/PM; and other variations… and can filter by locale 
(for sense-making)   
Percentage:  percent values with a certain amount of decimal places (%)  
Fraction:  numbers of digits for fractions, fractional representations  
Scientific:  represents large numbers in exponential notation   
 
Text:  “Text format cells are treated as text even when a number is in the cell. The cell is 
displayed exactly as entered.”   
Special:  customized based on user needs (and enables text description of the “Special” 
type  
Custom:  custom data type with scripted handling of certain types of numeric data for 
more effective visual communications of numbers (directions, thresholds, frequencies, and 
others); applying rules or classes of rules to whole worksheet for every instance of the 
number:  [];[];[];[]; can use symbols to represent numbers  

  
[Resource Note:  A fun resource on using “custom” settings is available here:  https://youtu.be/tGY70sdpaLc.  There is a 
video on Excel shortcut key combinations:  https://youtu.be/Xe4U_-o_EWw.]     
 
Maintaining a pristine master set of Excel workbooks containing data.  The data types settings applied to the columns 
may change the data in the workbook, so save an original as a pristine master first before engaging with the data.  User 
error in filtering can also break row data integrity.   
 
Being security-conscious.  When accessing an online file or even an offline one with URLs, be careful about accessing 
hyperlinks.  Clicking on one hyperlink in an Excel file will enable all the hyperlinks in the file.  Be sure that you are 
receiving information from a trusted source.   
 

 
 
 

Figure 3.  The 
Representation of 
Large Numbers 

https://youtu.be/tGY70sdpaLc
https://youtu.be/Xe4U_-o_EWw
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Controlling for table width.  For those who have quite a few data columns and want to control for the width of a table, 
Excel enables fine-tuned controls.   
 

 
 

1. Highlight the table.   
2. Go to the Home tab -> Cells area -> Format button -> Column Width selection.   
3. Put in the number in the window.  The measurements (by default) are by inches.   

 
Inherited Excel files.  To see all macros in an Excel file with macros, go to the View tab -> Macros area -> Macros button 
-> View Macros…and read the Visual Basic text to see what is happening in the script.   
 
Figure 4.  Seeing all Macros in an Excel Workbook with Macros Capabilities  

 
 
To see all formulas in an Excel workbook, go to the Formulas tab -> Formula Auditing area -> Show Formulas button…   
 
Figure 5.  Seeing all Formulas in an Excel Workbook with Formulas 
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3D Mapping with General Place / Location Data  

• 3D Mapping Tour [Open Excel with the data.  Open the 3D Maps.  Select the data you want to include.  In the 3D 
Map dropdown, “Add Selected Data to 3D Maps,” and select desired data features to visualize.] 

• The map is interactive and three-dimensional.  The visual can be changed to 2D as well.   
• A recorded video may be made of the visual changes to the map within the tool.   

 
Figure 6.  A Built-in 3D Maps Feature in Excel (requiring very light informational inputs) 

 
 

The selecting of non-adjacent columns using the CTRL key while selecting columns does not work for the 3D mapping 
visualization.   

Interactive Pivot Tables (and Pivot Charts) for Summary Data Exploration  
• Need data to have variable names at top of data columns  
• Pivot tables for data summarization (includes recommended ones based on the data)   
• Need to save a data sheet as a table if the table itself will be updated with new data that should show up in the 

pivot table (vs. a static data table that will not be updated with new information)   
• Pivot charts for data summarization  
• Can create slicers from any of the data dimensions (right-clicking on the object in the column name variable 

panel)   
 

Figure 7.  A Pivot Table View 
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Lookups for Individual Record Data Exploration / Queries:   
 

The lookups are by record…based on particular variables of interest.   
• If the column headers are used , then the VLOOKUP function is 
used.   
• If the row headers are used (as the main labels), then the 
HLOOKUP function is used.   

 
• VLOOKUP (Vertical Lookup) across rows (finding a value related to the leftmost column of data and a related 

corresponding value from another column, but in the same row, based on a defined relationship / formula) 
• HLOOKUP (Horizontal Lookup) across columns (using a value related to the topmost row and finding a related 

corresponding value across columns…in rows) 
o (V/H)Lookup Formulas:  (lookup_value, table_array, col_index_num, [range_lookup])   

 lookup_value = first value of interest (usually identifier) in the leftmost column or the topmost 
row  

 table_array = entire data table (extraneous data does not matter) 
 col_index_num = column of interest by basic count (1, 2, 3…) 
 [range_lookup] = true (if fuzziness or approximation or proxemic okay), false (if exact result 

desired) … The square brackets mean that an input is not needed. The default is “true” for 
approximated values.   

o For both, “named ranges” may be created to enable referencing multi-columns simultaneously using a 
named variable.   

o The arguments have to be set correctly the first time and can be re-used from there-on out…and shared 
with others.  The point is to test with simple data first…to ensure that everything is working as desired.   

• [Resource Note:  One helpful video is at https://youtu.be/E7gQ-PgYkMc.  For 
more on the new XLOOKUP, please check https://youtu.be/xnLvEhXWSas. ]   
 
Index- Match:   A more sophisticated approach involves using Index  -  Match.  A 
helpful video is at https://youtu.be/F264FpBDX28.  This involves indexing or 
mapping data (a column or a whole table, location-to-location in the data array) 
and then using a matching function (from one column to particular data)…to 
create an interactive dropdown that enables light data exploration.   
 
 

 

VLOOKUP across vertical columns 
HLOOKUP across horizontal rows

Figure 8.  (Vertical and Horizontal) Lookups for Targeted 
Queries  

Figure 9.  An Index-Match Application 
on Open-Source USDA Data about 
Entrees and Accompanying Condiments  

https://youtu.be/E7gQ-PgYkMc
https://youtu.be/xnLvEhXWSas
https://youtu.be/F264FpBDX28
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Making a Dropdown List 
 
1. Click on a cell to activate.  
2. Go to Data tab.  Go to Data Tools area and Data Validation.   
3. Select Data Validation in the Dropdown.   
4. In the Dropdown, choose List.   
5. Identify the column source for the list (of identifiers).   
6. Select all.  (Keyboard shortcut:  CTRL + SHIFT + downwards 
arrow key (↓▼) 
7. Click OK.  (This is a kind of workaround by using data validation 
to select in the contents that you want.)   
 
 

 
 
Creating Interactive Data Dashboards 
 

• Set up the data in Excel.   
• Set up pivot tables in a new sheet (with the selected features).  Name the new sheet.   
• Analyze -> Pivot Chart…  Clean up the pivot chart data visualization.  Swap in the desired text for proper labeling.  

Style it in the way that you want visually.   
• Make a new sheet for the dashboard.  Emplace the pivot table through copy-and-paste.   
• Continue until there are sufficient pivot charts.  Place them in a logical order from top-to-bottom (and left-to-

right).   
 
To Make a Slicer in the Dashboard 
 

• Highlight a pivot table or pivot chart (interactive data visualization).  Go 
to the activated Analyze tab above.  Insert Slicer (an interactive filtering tool 
based on a selected dimension).  Select the data column variable used for the 
filtering.  The Slicer appears in the spreadsheet. Copy and paste it into the 
dashboard.  The Slicer is a visual interactive filtering feature on the dashboard.   
• Then, connect all the charts with the slicers.  Right click the slicer and 
select the Report Connections Region, and connect the slicer to all pivot tables. 
Do so for each slicer.  When mouse over-ing the slicers, the data visuals will 
change.  [Resource Note:  One video resource about creating a dashboard with 
slicers is available at https://youtu.be/RM8T1eYBjQY.]   

 
Dynamic Arrays in Excel…   A recent feature in Excel involves the built-in formulas that return arrays of data (collections 
of entities).  The main built-in array functions are FILTER, UNIQUE, SORT, SORT BY, SEQUENCE, RANDARRAY.  A detailed 
video about this functionality is available at  https://youtu.be/BsUTlhib4Tw.  A simpler and shorter video is here:  
https://youtu.be/2USJsIyIzvo.  (This works on Excel 2019 and Excel in O365…with array formula features released in late 
2018 and the update to Microsoft Excel’s calculation engine.)  [Ctrl+ Shift + Enter was used in the past for array 
formulas.] 
 
About keyboard shortcuts, many of the common ones in the Microsoft Suite (esp. in Word) work the same in Excel.  
More are available here:  https://support.office.com/en-us/article/keyboard-shortcuts-in-excel-1798d9d5-842a-42b8-
9c99-9b7213f0040f.   
 
Working with Textual Data?  Excel’s “data” tab has some ways to subtotal counts of regularized text responses (such as 
from surveys).  

Figure 10.  Creating a Dropdown List in Excel  

Figure 11.  Inserting a Slicer after a Pivot Table 
or Chart has Been Made for Easier Interactivity 
with the Data by Users  

https://youtu.be/RM8T1eYBjQY
https://youtu.be/BsUTlhib4Tw
https://youtu.be/2USJsIyIzvo
https://support.office.com/en-us/article/keyboard-shortcuts-in-excel-1798d9d5-842a-42b8-9c99-9b7213f0040f
https://support.office.com/en-us/article/keyboard-shortcuts-in-excel-1798d9d5-842a-42b8-9c99-9b7213f0040f
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About the Data Tab:  The data tab offers a range of ways to sort, filter, clean, validate/invalidate, de-duplicate, group, 
and otherwise engage data.   
 
Figure 12.  The Data Tab 

 
 

Finally, Why Excel? 
 
Why Excel?  In Excel, you can work with the graphical user interface / visuals, built-in pre-set macros, and / or line 
formulas (for those who like command line-interactions).  Functions are represented multiple ways simultaneously for 
meaning-making.  Excel plays well with a lot of other tools.  Even if people use more sophisticated ways to engage data, 
it helps to know how to use Excel.   
 
If you’re just starting out, going to data.gov may be helpful because they offer a range of data and data type downloads 
for learning.  Many of the sharers of the data follow good practices, with README data, bylines and crediting, data 
dictionaries, data visualizations, data dashboards, and other elements.   
 
At K-State, we have access to the ProQuest TDM Studio (Text and Data Mining Studio), which enables various data 
visualizations…from shadow datasets…and related data that exports into Excel.  This web-based tool for text and data 
mining is made available by the K-State Libraries.  For information about how to access this tool, go to their website, and 
go to their subscription databases area…and look up “TDM Studio.”   
 
Original Release Date of Excel 1.0:  Sept. 30, 1985 (for our trivia fix)   
 
 
Presenter:   Dr. Shalin Hai-Jew 

               ITS, Kansas State University  
  785-532-5262 
  shalin@k-state.edu  
 
Copies of this handout (evolving) may be accessed at the following URLs:  
 

PDF version:  https://idme-test.ome.ksu.edu/MSExcelO365.pdf 
MS Word version (as a download):  http://www.k-state.edu/ID/MSExcelO365.docx   

 
[Updated:  2023]  
 
 
Part 4.  Typical Work Sequence (and sub-sequences) in Excel  (extra)   
 

1. Open Excel.   
2. Input data manually (using copy and paste or other means).  (Or capture by downloading data from a website or 

exporting data from a database.)   
3. Check the data for correctness.   
4. Save a pristine master of the data before any further processing.  Use informative naming protocols for the Excel 

workbook.    
5. Merge / combine / aggregate (union) selected data as needed.  (This assumes that there is an identifier column 

which enables the ability to match data between tables.)   

mailto:shalin@k-state.edu
https://idme-test.ome.ksu.edu/MSExcelO365.pdf
http://www.k-state.edu/ID/MSExcelO365.docx
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6. Clean and process the data (as needed).   
7. Select particular data ranges for study.  (Usually, data arrays are depicted visually in sections.  In some cases, full 

datasets may be studied simultaneously such as for factor analyses.)   
8. Explore and analyze the (selected) data through various queries, statistical analyses, and data visualizations.  

Sanity-check the findings and results.   
9. Create a number of finalized data visualizations, and exported (or screenshot).   
10. Export the data in various formats for analysis in outside software tools.   
11. Archive.   
12. Create a sharable Excel workbook of data that is sufficiently de-identified / anonymized and with a README 

section.  (A README file usually addresses data sources, data representations, data table setup, contact 
information, and other relevant information.)   

 
A related workflow follows on the next page.   
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