1. K-State home
  2. »iSIS
  3. »News & Updates
  4. »Internet Explorer 10 Requires Compatibility Mode

iSIS

Internet Explorer 10 Requires Compatibility Mode

Internet Explorer 10 is the latest version of Microsoft's web browser.  IE 10 is delivered with Windows 8, and as an important update to Windows 7 as part of Microsoft's update process.

In order for IE 10 to work correctly with iSIS the compatibility mode must be enabled and the pop-up blocker disabled

Below are links to step-by-step instructions to make IE 10 work correctly with iSIS.  These instructions work for both Windows 7 and Windows 8.